Compatibildad de aplicaciones JAVA con Celulares

jack
31 de Diciembre del 2008
Aprendi a programar en java en la unviersidad, ahora me baje un curso para programar java para celulares; y veo que es muy muy parecido, cambian algunas cosas en cuanto a las clases de uso... el caso es que haciendo una primera aplicacion de un ejemplo del curso "PROGRAMACIÓN DE JUEGOS PARA MÓVILES
CON J2ME" por Alberto García Serrano; mi aplicacion corre perfeectamente con el emulador (solo era una simple pantalla de bienvenida y unos mensajeitos); lo compile, y empaquete de modo que ahora tengo una aplicacion .jar; lo trato de instalar en mi movil pero dice: "Error al realizar operacion" (Sony Ericsson k550i); si instalo otras aplicaciones ya hechas por terceros, no hay problemas...

entonces pienso en los problemas de compatibilidad con algunos equipos...
quisiera saber lo que tengo que hacer para poder adecuar mi aplicacion a mi celula.

Alguna idea?

jack
31 de Diciembre del 2008
bueno; gracias de todos modos; les dejo la respuesta, si alguno tiene los mismos problemas que yo.
El problema reside en la version de las apis usadas; asi que tengan cudiado...
yo deje mi aplicacion con las mas basicas y comerciales; aqui les dejo una captura de imagen:
http://img187.imageshack.us/img187/4776/apips5.png