Actualización en librería cURL

"cURL" es una librería y herramienta para descargar ficheros por Gopher, FTP, FTPs, HTTP, HTTPs, telnet, DICT, FILE y LDAP. Las versiones de "cURL" anteriores a la 7.13.1 contienen varios problemas de seguridad que permiten que un servidor remoto malicioso ejecute código arbitrario en la máquina cliente, con los privilegios del usuario que invoca "cURL". Las vulnerabilidades son: * Desbordamiento de búfer en la autenticación Kerberos del protocolo FTP: Este ataque permite que un servidor FTP remoto, malicioso, pueda ejecutar código arbitrario en la máquina cliente "cURL", con los privilegios del usuario que haya invocado el comando. * Desbordamiento de búfer en la autenticación del protocolo NTLM: Este ataque permite que un servidor HTTP remoto, malicioso, pueda ejecutar código arbitrario en la máquina cliente "cURL", con los privilegios del usuario que haya invocado el comando. La autenticación NTLM es utiliza en entornos Microsoft Windows. Ambas vulnerabilidades afectan también a los programas que utilicen la librería "libcurl". Los programas enlazados de forma dinámica con la librería deben ser reiniciados, para que empleen la versión correcta. Los programas que se enlacen de forma estática deben ser recompilados/reenlazados. Hispasec recomienda a todos los usuarios de "cURL" que actualicen cuanto antes a la versión 7.13.1. Más Información: cURL / libcURL Kerberos Authentication Buffer Overflow Vulnerability http://www.securityfocus.com/bid/12616 cURL / libcURL NTLM Authentication Buffer Overflow Vulnerability http://www.securityfocus.com/bid/12615 Previous Security Flaws and Advisories http://curl.haxx.se/docs/security.html cURL and libcurl http://curl.haxx.se/
COMPARTE ESTA NOTICIA

ENVIAR A UN AMIGO
COMPARTIR EN FACEBOOK
COMPARTIR EN TWITTER
COMPARTIR EN GOOGLE +