¡AYUDA URGENTE! ======> javax.swing

Pedro
09 de Enero del 2004
haber si alguien me puede ayudar

he instalado la ultima version de J2SE sobre LINUX.......

y necesito importar en un paquete la libreria JAVAX.SWING.*

pero redirijo el CLASSPATH y x mas que añado lineas de /lib no lo encuentra

alguien sabe donde esta??

por favor, ayuda, es muy urgente

Pedro
09 de Enero del 2004
una cosa se me ha olvidao deciros

he probado a añadir al classpath el fichero rt.jar, pero al añadirlo me da errores de versiones (siempre en conflicto las mismas versiones)....en los paquetes java.awt y java.lang

WRONG VERSION: 48, EXPECTED 45

chuidiang
09 de Enero del 2004
Si has descargado un J2SE moderno, no necesitas poner nada en el classpath (salvo tus propias clases que esten en otros directorios distintos del actual).

En el código java que necesites cosas de swing, basta con poner

import javax.swing.*;

o bien la cosa concreta, por ejemplo

import javax.swing.JLabel;

Se bueno.