Esta es la definitiva: Webalizer y JSP, problemas

Ana
19 de Abril del 2005
Hola a todos/as

Os comentaré mi problema, llevo ya varios días con él, y de verdad, empiezo a estar muy desesperada, por lo cual os estaria muy agradecida si alguien me pudiera ayudar, ya que he vagado de foro en foro buscando ayuda y por desgracia, nadie ha podido ayudarme...paso a comentarlo:

Vereis, tengo el webalizer para generar las estadisticas de mi aplicación en Apache y bueno, la idea es que en mi jsp, tengo dos enlaces, uno para generar estadisticas y otro para consultarlas...

Los que sepan algo de webalizer, sabreis que existe un fichero que por defecto se llama webalizer.conf que contiene una serie de parametros y atributos que configuran las estadisticas y todo tipo de pormenores para que webalizer funcione a nuestro gusto, pues bien, yo tengo ya configurado ese archivo tal y como lo necesito, cuando lo ejecuto manualmente, es decir, desde windows...webalizer.exe se ejecuta usando webalizer.conf, funcionando de esa forma perfectamente...

Ahora bien, el problema está, en que si trato de ejecutar webalizer.exe desde mi jsp, ejecutarse se ejecuta, pero es como si no cogiera el webalizer.conf que tengo configurado...ya que ni encuentra el history file, ni el archivo log, ni el directorio de output...en fin, nada de nada...he probado ya varias cosas, pero nada me sirve:

A)
Runtime rt = Runtime.getRuntime();
rt.exec(Ruta + "/webalizer/bin/webalizer.exe");

B)
Runtime rt = Runtime.getRuntime();
rt.exec(Ruta + "/webalizer/bin/webalizer.exe -c webalizer.conf");

C)
Runtime rt = Runtime.getRuntime();
rt.exec(Ruta + "/webalizer/bin/webalizer.exe -c "+RutaConf+ "/webalizer/bin/webalizer.conf");

En fin, he probado ya tantas cosas que estoy totalmente desmoralizada...en fin, ojalá me podáis ayudar, os estaría muy agradecida

Un saludo