¡¡AYUDA CON XP POR FAVOR!!

IJCHAPER
14 de Febrero del 2004
Hola:
Tengo el siguiente problema: Tengo una aplicación que desarrolle con visual basic 6 edicion profesional, e hice los instaladores en una pc que tiene windows 2000 profesional con service pack 4, al momento de instalar dicho sistema en windows 2000 que no tenga SP4 me dice que lo actualice, le instala SP4 y la instalacion ocurre sin problemas, pero si uso este mismo instalador en un pc con Windows XP, me manda el mismo mensaje (de que necesita actualizarce), y como es logico el SP4 no le sirve, ¿necesito crear un instalador en una pc que tenga XP para que pueda funcionar el instalador en pc con XP?

ayuda por favor