No hagais caso a este personaje--> Osiosus Maximus tontus

al
03 de Junio del 2004
Hola a todos!!
no le sigais el juego a gente(por llamarle algo) como ese, no creo que se merezca ni un segundo de nuestro tiempo, aqui estamos para ayudarnos no para aguantar a discipulos de Krusty el payaso.
Saludos a todos!(menos ya sabeis quien)

osioso sin nada que hacer
03 de Junio del 2004
ey dices que no me sigan el juego y que no merezco un
segundo de su atencion, pero tu acabas de hacer lo contrario y te apuesto que ahorita estas leyendo esto , me sigues prestando atencion quien es mas imbecil , te aseguro que yo lo soy bastante pero tu mas por prestarme atencion y leiste hasta el final no que imbecil

peris
03 de Junio del 2004
hola al!
estoy de acuerdo contigo, pero esque gente así me exaspera...

Bueno yo no tengo na que hacer así que...
a ti que tal te va? ya se que te queda poquito para acabar y vacaciones eh??

yo acabo hoy, así que estoy vagueando a lo grande jejeje.

bueno saludos y por adelantado gracias por las dudas de que me hayas sacado, a buen seguro más de una a sido.

al
03 de Junio del 2004
Hola pues la verdad estoy atascao con el boton de activar que se supone que deberia funcionar..
La verdad es que yo no he resuelto muchas dudas, pero he intentado ayudar todo lo que he podido. Espero que tengas suerte porque te lo mereces.
Bueno si puedes ayudarme un poco(aunque no se si sabes algo de APIS..) a mirar un codigo te lo agradecere.
gracias y espero tu respuesta.

peris
03 de Junio del 2004
Pues mira, en el tema tuyo no te puedo ayudar casi nada porque he usado poco las apis, si quieres puedo mirarte por algunas páginas por la red a ver si tienen algo que te pueda valer, dime que api es de la que quieres info y yo te la busco.

más no puedo hacer lo siento.

al
03 de Junio del 2004
En realidad no es un codigo muy complejo, estoy con la API getmenuitemid(ya se de que va) pero es que me devuelve un valor muy raro por ejemplo: 3009.
te pongo el codigo del boton Activar:
Private Sub boton_Click()
Dim SubMenu As Long
Dim y As Long
Dim w As Long
Dim Item As Long
AppActivate (retval)
For y = 0 To lst1.ListCount - 1
If lst1.Selected(y) = True Then
SubMenu = GetSubMenu(hMenu, y)
MsgBox SubMenu

MsgBox "Elemento seleccionado del primer listbox " & y

End If
Next

For w = 0 To Lst2.ListCount - 1
If Lst2.Selected(w) = True Then

Item = GetMenuItemID(SubMenu, w) "obtengo el ide del menu"
SendMessage Ventana, WM_COMMAND, Item, 0
MsgBox Item

MsgBox "Elemento seleccionado del segundo listbox " & w
End If
Next

End Sub

Bueno si puedes decirme algo te agradecere cualquier ayuda. Muchas gracias y espero tu respuesta.



peris
03 de Junio del 2004
y sabes en que lugar te da error? hmenu que es, el nombre del menú principal?

al
03 de Junio del 2004
Hola Peris!!
el Hmenu es el handle del menu(el manejador), y no me sale un error como tal lo que ocurre es que he preguntado en otro foro y me ayudaron con esto, un usuario me dijo que este codigo a el le funcionaba pero a mi no. Yo creo que puede ser algo sospechoso que la variable item me coja un 3009(no puede corresponder con un menu..)
Gracias y espero tu respuesta.

peris
03 de Junio del 2004
He estado mirando el código, y creo que está bien, el 3009 te refieres al valor de la variable item, que a su vez recoge el valor que devuelbe la funcion getmenuide esa.

pues si es así yo creo que el valor que devuelba una función es correcto, a no ser claro, que los parámetros no sean correctos, pero parece una función muy simple, y no le veo nada raro.

creo que el código es correcto y te falla seguramente por algo ajeno a él.

al
03 de Junio del 2004
Gracias Peris, la verdad yo creo que el error viene del handle de la ventana activa que no me lo coge bien pero no se porque, a ver si lo resuelvo. Gracias por todo.

osioso sin nada que hacer
03 de Junio del 2004
error '8020' al leer del dispositivo comm

Enviado por jarld el día 28 de mayo de 2004

Tengo un móvil conectado a un puerto usb configurado como puerto serie (virtual com 5). Hice un programa terminal con el MSComm que funciona correctamente con otros modems, envía y recibe carácteres, pero con el com5 y el móvil, falla al recibir mostrando el mensaje de error del título:
comReadError 8020 Error reading comm device. Si alguien tiene idea a que se puede deber. gracias.

eso dile a el nesesita muchaaaa ayuda

osioso sin nada que hacer
03 de Junio del 2004
el menu principal es por donde mejor de cabe pendeja

peris
03 de Junio del 2004
oye ya, muchas preguntas, que se me hace que eres virgen y quieres que te culeee.

osioso sin nada que hacer
03 de Junio del 2004
mira pendeja ese pinchi supuesto problema no es mio es de otro wey de este foro al que se lo copie nomas pa que me sigas poniendo atencion babosaaaaaaaa

peris
03 de Junio del 2004
si no me has ayudado no te ayudo cabrona huevona, ponte a estudiar