asp, dream y access y no me anda la base de datos

goops
20 de Agosto del 2003
ya lo puse en wwwroot y y todo eso, kiero hacer un login y registrarse y al presion darme de alta se abre el alta.asp, y no me aparece ningun error ni nada mi explorer keda blanco!!!! y al ver mi base de datos no me lo carga. ke puede ser???
aki tengo el codigo para ke alguien me diga si esta algo mal
asp:
<body>
<%
Dim nombre, apellidos, telefono, email, login, password
Dim correcto
Dim oConn, rs, SQL

'Recogemos el formulario
nombre=Request.Form("nombre")
apellidos=Request.Form("Apellidos")
telefono=Request.Form("Telefono")
E-mail=Request.Form("E-mail")
login=Request.Form("login")
password=Request.Form("password")
correcto=True
'Comprobamos que no hay campos vacos
if nombre="" then correcto=False end if
if apellidos="" then correcto=False end if
if telefono="" then correcto=False end if
if E-mail="" then correcto=False end if
if login="" then correcto=False end if
if password="" then correcto=False end if

if correcto then
'Solo si todo est bien, comprobamos con la bd

set oConn=Server.CreateObject("ADODB.Connection")
'Abro la conexin
oConn.Open "DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=" & Server.MapPath("C:Inetpubwwwrootusuario.mdb")

'oConn.Open ...
SQL="SELECT * FROM usuario WHERE (Login='"&login&"');"
'Ejecutamos la consulta
set rs=oConn.Execute(SQL)

'si no nos devuelve vaco es que el login ya est en uso
if not rs.EOF then
Response.Write("El nombre de usuario ya est siendo utilizado. ")
Response.Write("Por favor, escoja otro.")
else
' es vacio, as que le insertamos en la bd
SQL="INSERT INTO usuario " & _
"(Login, Password, Nombre, Apellidos, Telefono, Email)"
SQL=SQL & " VALUES ('"&login&"', '"&password & _
"', '"&nombre&"','"&apellidos&"','"&telefono&"','"&email&"');"
oConn.Execute(SQL)
Response.Write("Gracias por registrarte, "& nombre)
end if

'Limpiamos objetos
rs.Close
oConn.Close
set rs=nothing
set oConn=nothing
else

'El usuario ha metido datos incorrectos
Response.Write("Datos incorrectos!")
end if


%>
y en el dream puse asi:

<div id="Layer1" style="position:absolute; left:74px; top:50px; width:118px; height:27px; z-index:1">Nombre</div>
<div id="Layer2" style="position:absolute; left:69px; top:100px; width:123px; height:24px; z-index:2">Apellidos</div>
<div id="Layer3" style="position:absolute; left:65px; top:139px; width:126px; height:27px; z-index:3">Telefono</div>
<div id="Layer4" style="position:absolute; left:66px; top:181px; width:128px; height:26px; z-index:4">E-mail</div>
<div id="Layer5" style="position:absolute; left:63px; top:226px; width:137px; height:30px; z-index:5">Login</div>
<div id="Layer6" style="position:absolute; left:64px; top:270px; width:133px; height:28px; z-index:6">Password</div>
<div id="Layer7" style="position:absolute; left:225px; top:47px; width:168px; height:34px; z-index:7">
<form name="Nombre" method="post" action="alta.asp">
<input name="Nombre" type="text" id="Nombre">
</form>
</div>
<div id="Layer9" style="position:absolute; left:222px; top:141px; width:200px; height:26px; z-index:9">
<form name="Telefono" method="post" action="alta.asp">
<input type="text" name="Telefono">
</form>
</div>
<div id="Layer10" style="position:absolute; left:229px; top:184px; width:149px; height:25px; z-index:10">
<form name="E-mail" method="post" action="alta.asp">
<input type="text" name="E-mail">
</form>
</div>
<div id="Layer11" style="position:absolute; left:232px; top:229px; width:150px; height:28px; z-index:11">
<form name="login" method="post" action="">
<input type="text" name="login">
</form>
</div>
<div id="Layer12" style="position:absolute; left:230px; top:274px; width:144px; height:15px; z-index:12">
<form name="password" method="post" action="">
<input type="text" name="password">
</form>
</div>
<div id="Layer13" style="position:absolute; left:162px; top:353px; width:103px; height:39px; z-index:13">
<form name="ACTION" method="post" action="alta.asp">
<input type="submit" name="Submit" value="Dar de alta">
</form>
</div>
<div id="Layer8" style="position:absolute; left:228px; top:100px; width:182px; height:23px; z-index:14">
<form name="Apellidos" method="post" action="">
<input type="text" name="Apellidos">
</form>
</div>
</body>

es mi primer asp ya probe ese ke dice hola xDD
y me anda asi ke .. el ke se digne de mi por favor!!!!!!!! asi ke estoy en desesperacion y kiero patiar mi pc


JuanJo
20 de Agosto del 2003
Hola.

Si se te queda el explorador en blanco y no te da errores es que la pgina se ejecuta bin, lo nico que se me ocurre es que las capas (div) que has definido estn ocultas, aade visibility:visible al style de todos los div.

Saludos.