problemas con los datos del formulario

daniel ivan
12 de Septiembre del 2002
Buenasss!!!
Estoy cansado de dar vueltas y de no encontrar el fallo. Me pasa algo muy raro. Tengo una pgina web con un formulario simple. El problema viene cuando lo envio a la pagina asp para que lo meta en una base de datos. Accedo a los datos con Request.Form("txtDescripcion"), y me mete datos vacios a la base de datos. El problema es que al acceder a los datos, aparecen vacios, y es rarisimo.Lo intente enviar con el metodo GET, aparecen los datos en la url, pero sin embargo al hacer un request.write("txtDescripcion"),no escribe nada. ¿Alguien sabe lo que me puede pasar?
Muchas gracias por anticipado.

vivianita
12 de Septiembre del 2002
no soy muy experta pero yo hice un ingreso, ojala te sirva porque esta bueno.
<%
coordinador=request.form("coordinador")
response.write coordinador

correo=request.form("correo")
response.write correo

set rs = Server.CreateObject("ADODB.recordset")
sql = "insert into coordinador (coordinador, correo) values ( '" & coordinador & "', '" & correo & "' )"

con.execute (sql)
set rs2 = Server.CreateObject("ADODB.recordset")
sql = " select * from coordinador "
rs2.open sql, con

while not rs2.eof
response.write rs2("coordinador")
response.write rs2("correo")

rs2.movenext
wend
suerte.....
ve si me puedes ayudar a mi please ok?
byeeeeee.........

daniel ivan
12 de Septiembre del 2002
Bufff, eso ya lo he intentado. Y unas cuantas cosas mas, como lo de usar la misma pagina web para hacer el formulario y para recoger la informacion. Pero es rarisimo. No se si ser porque habr q configurar algo.
Pero muchas gracias de todas formas. A ver si a alguien le pas lo mismo.

vivianita
12 de Septiembre del 2002
obviamente tienes que incluir esto que es la conexion a la base de datos:
<%public coordinador, correo
strconn = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & Server.MapPath("../shop/contactenos.mdb")
set con = Server.CreateObject("adodb.connection")
con.open strconn
%>