consulta excel muy interesante....(definitiva)

xevi
30 de Diciembre del 2004
Haber si alguien es capaz de responderme a la siguiente duda, ya que me estoy volviendo loco, y lo necesito, se me presenta el siguiente problema:

Tengo una tabla en el siguiente formato:

CLIENTE GASTO IMPORTE
1000 TRANSP 1000
1000 COMIDA 200
1001 TRANSP 50
1001 COMIDA 10

Esto podriamos decir que es la base de datos,
Mi cuestion es la siguiente,

yo quiero hacer de un modo automatizado, que insertando en una tabla nueva el nº de cliente me rellene los gastos correspondientes, con esta tabla

cliente: 1001

transp:
comida:
TOTAL:

La dificultad que encuentro es que tengo dos condicionales, que me coincida el nº de cliente con el tipo de gasto,

Espero que me podais ayudar ya que no encuentro la manera de realizar esta labor....
Muchas Gracias.

josaca
30 de Diciembre del 2004
Se podría usar la función BDSUMA, la cual suma los números de una columna de una matriz o base de datos que conincidan con los criterios:

Ejemplo:

Esto seria la matriz o base de datos A1:C5

CLIENTE GASTO IMPORTE
1000 TRANSP 1000
1000 COMIDA 200
1001 TRANSP 50
1001 COMIDA 10

Criterios: A8:B9 para Transp y C8:D9 para comida

CLIENTE GASTO CLIENTE GASTO
=B12 TRANSP =B12 COMIDA

Los resultados serían:

CLIENTE: 1001 (esto es B12 donde pones el cliente)

TRANSP =BDSUMA(A1:C5;C1;A8:A8:B9)
COMIDA =BDSUMA(A1:C5;C1;C8:D9)
TOTAL =SUMA(B14:B15)

Nota las celdas sólo son de referencia, tu puedes ponerlas donde quieras, pero la forma en que están los criterios debe ser así (un nombre de campo y abajo el criterio)

Espero que te sirva que estes bien