Error SQL7008

fran-ki
05 de Julio del 2005
Hola, tengo un pequeño problema.
Tenía una aplicación funcionando bajo Weblogic 6.1 apuntando a una base de datos DB2 en AS400. La aplicación funcionaba sin problemas. Pero ahora han migrado el servidor de weblogic a la versión 8.1. La aplicación sigue siendo la misma y la base de datos tambien, y todo funciona correctamente excepto que ahora no puedo actualizar la base de datos. Puedo hacer consultas sin problemas, pero no un UPDATE.
El error que se produce es el siguiente:
[SQL7008] FPCLI de FID4FIL no v?lido para la operaci?n.
He estado informandome un poco, y parece ser que puede tener algo que ver con un tema de journals en la base de datos, pero el caso es que con la versión 6.1 de Weblogic no daba ningún problema, y hay otra aplicación que accede tambien bajo Weblogic 8.1 a la misma base de datos y no tiene ningún problema. ¿Alguien podría orientarme?
Muchas gracias de antemano.