Consulta simple

jojolas
29 de Septiembre del 2003
holas, tengo una duda... que necesito para poder trabajar con SWING?? porque yo solo he trabajado con interfaces AWT y creo que para utilizar cosas como jframe etc es necesario alguna version especifica de java... ojala alguien me responda, gracias

chuidiang
29 de Septiembre del 2003
Para usar swing solo necesitas una versión de java que no sea muy muy antigua antigua (creo que a partir de java 1.2 ya lo tiene).

Se usa igual que awt, pero es otro paquete

import javax.swing.*;

y son otras clases (JFrame , JButton, etc)

Se bueno.

jojolas
29 de Septiembre del 2003
muchas gracias... yo tengo el java 1.1.8, tendre que bajar otra version entonces... hay alguna que sea recomendable??