Problemas con Eclispe

dimitriv
22 de Febrero del 2006
Recientemente he estado chocando con un problema. Una vez instalado el jdk, y exportar las variables de entorno correspondiente JAVA_HOME, y JAVA_BIN, adicionandolas al PATH, en /etc/profile, se hace un source /etc/profile. Al ejecutar el eclipse me da me informa que ha ocurrido un error el cual adjunto a continuacion:

Pense inicialmente, que eran problemas de permisos, hice un
chmod -R 777 /usr/local/Eclipse.
Utilice un truco que encontre en un pdf. Eclipse al iniciar necesita poder escribir, y hacer un sin numero de operaciones, por tal causa, es necesario, necesita poder escribir en dicho directorio, segun lo que lei, no es tan asi, se puede hacer un scripts, que invoque el eclipse, pero en este directorio, debe tener los permisos. Muy bello pero no funciono.
Lo copie bajo el directorio home, sin que conservara los permisos y conservandolo y no funciono.

Le eche un vistazo al readme que trae eclipse muy instructivo,pero en muchas ocasiones no me dice como resolver los problemas.
No creo que sea un problemas de permisos, pues de echo el eclipse, puede crear los ficheros log en su directorio.
Y yo como usuario, puedo hacer lo que me plazca.
- Mas bien creo que se trata de un problema de configuracion.
- Lo mas gracioso que cada vez que le intento instalar el eclipse a alguien, siempre me encuentro con el mismo error.

Gracias de Antemano, y por el hecho de tener la paciencia de leer.


!SESSION 2006-02-20 09:31:23.349 -----------------------------------------------
eclipse.buildId=I20050513-1415
java.version=1.5.0_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=es_ES
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.core.runtime 2006-02-20 09:31:24.885
!MESSAGE Product org.eclipse.platform.ide could not be found.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:24.942
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:208)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:371)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:160)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:330)
at org.eclipse.core.launcher.Main.basicRun(Main.java:274)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)

!ENTRY org.eclipse.osgi 2006-02-20 09:31:24.966
!MESSAGE Bundle [email protected]/org.eclipse.ant.ui_3.1.0.jar [4] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:24.966
!MESSAGE Missing required bundle org.apache.ant_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:24.966
!MESSAGE Missing required bundle org.eclipse.jdt.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:24.967
!MESSAGE Missing required bundle org.eclipse.jdt.debug.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:24.967
!MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:24.988
!MESSAGE Bundle [email protected]/org.eclipse.help.base_3.1.0.jar [19] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:24.988
!MESSAGE Missing required bundle org.apache.lucene_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:24.993
!MESSAGE Bundle [email protected]/org.eclipse.help.ui_3.1.0.jar [20] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:24.994
!MESSAGE Missing required bundle org.eclipse.help.base_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:25.12
!MESSAGE Bundle [email protected]/org.eclipse.jdt.debug.ui_3.1.0.jar [24] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.13
!MESSAGE Missing required bundle org.eclipse.jdt.debug_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.13
!MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.13
!MESSAGE Missing required bundle org.eclipse.jdt.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:25.15
!MESSAGE Bundle [email protected]/org.eclipse.jdt.junit.runtime_3.1.0/ [28] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.15
!MESSAGE Missing required bundle org.junit_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:25.17
!MESSAGE Bundle [email protected]/org.eclipse.jdt.launching_3.1.0.jar [30] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.18
!MESSAGE Missing required bundle org.eclipse.jdt.debug_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:25.30
!MESSAGE Bundle [email protected]/org.eclipse.jdt.ui_3.1.0.jar [32] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.31
!MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:25.33
!MESSAGE Bundle [email protected]/org.eclipse.pde.junit.runtime_3.1.0/ [44] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.33
!MESSAGE Missing required bundle org.eclipse.jdt.junit.runtime_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.33
!MESSAGE Missing required bundle org.junit_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-20 09:31:25.37
!MESSAGE Bundle [email protected]/org.eclipse.pde.ui_3.1.0.jar [47] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.37
!MESSAGE Missing required bundle org.eclipse.jdt.debug.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.38
!MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.39
!MESSAGE Missing required bundle org.eclipse.jdt.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.39
!MESSAGE Missing required bundle org.eclipse.pde.build_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.39
!MESSAGE Missing required bundle org.eclipse.ant.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.40
!MESSAGE Missing required bundle org.eclipse.jdt.junit_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-20 09:31:25.40
!MESSAGE Missing required bundle org.eclipse.help.base_0.0.0.