PROBLEMAS GENERANDO REPORTES

Oscar Mauricio Gomez
24 de Agosto del 2005
TENEMOS ESTAS LIBRERIAS:
import net.sf.jasperreports.engine.design.JasperDesign;
import net.sf.jasperreports.engine.design.JRDesignQuery;
import net.sf.jasperreports.engine.JasperManager;
import net.sf.jasperreports.engine.JasperReport;
import net.sf.jasperreports.engine.JasperPrint;
import net.sf.jasperreports.engine.JasperPrintManager;
import net.sf.jasperreports.view.JasperViewer;
import net.sf.jasperreports.engine.JRException;


Y LLAMAMOS AL JASPERREPORT DE LA SIGUIENTE MANERA

try{
jasperPrint = JasperManager.fillReport(getClass().getResource(Reporte).getPath(), null, Conex.con);
JasperViewer.viewReport(jasperPrint,false);
}catch(Exception e){
javax.swing.JOptionPane.showMessageDialog(null,"No se pudo ejecutar el reporte.nERROR: "+e.toString());
}



Y NOS SALE EL SIGUIENTE ERROR:
java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
at net.sf.jasperreports.engine.fill.JRBaseFiller.<clinit>(JRBaseFiller.java:84)
at net.sf.jasperreports.engine.fill.JRFiller.fillReport(JRFiller.java:67)
at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillManager.java:247)
at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillManager.java:163)
at net.sf.jasperreports.engine.JasperManager.fillReport(JasperManager.java:620)
at integra.Reportes.Ejecutar_Reporte(Reportes.java:45)
at integra.Frmrut.btn_Limpiar1ActionPerformed(Frmrut.java:391)
at integra.Frmrut.access$1400(Frmrut.java:28)
at integra.Frmrut$14.actionPerformed(Frmrut.java:355)
at java.awt.Button.processActionEvent(Button.java:382)
at java.awt.Button.processEvent(Button.java:350)
at java.awt.Component.dispatchEventImpl(Component.java:3615)
at java.awt.Component.dispatchEvent(Component.java:3477)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

NO SABEMOS QUE HACER. AGRADECEMOS MUCHO SU AYUDA!!