Proyecto Eclipse(plugins)

bethlen
08 de Diciembre del 2008
Aun estoy empezando con Java y ayer me descargue eclipse 3.3 y un proyecto eclipse ejemplo.
Al intentar ejecutarlo me dio errores en los siguientes import:
import org.eclipse.swt.graphics.GC;
import org.eclipse.swt.graphics.Point;
import org.eclipse.swt.widgets.Shell;
import org.eclipse.swt.widgets.Display;
import org.eclipse.swt.layout.FillLayout;
import org.eclipse.swt.widgets.Canvas;
import org.eclipse.swt.SWT;
Alguien me podría decir que plugin de Eclipse me tengo que descargar?(si es q es ese el problema,claro ...)
Gracias XD

James
08 de Diciembre del 2008
El error se produce debido a que no tienes el plugin de SWT Standart Widget Toolkit, es, que basicamente es un conjunto de componentes graficos como botones listas y demas, pero no son estandart JAVA son creados por IBM y se usan es Eclipsey otros proyectos mas.

Personalmente te recomendaria que si vas a ampezar a utilizar JAVA uses cosas Standart luego puedes probar con SWT u otros, el eclipse de por si deberia funcionar con cualquier ejemplo de JAVA que no use SWT, o podrias usar Netbeans, que es lo que recomienda la SUN, es totalmente JAVA y trae incluidos unos muy buenos ejemplos para aprender un poco el lenguaje JAVA, Suerte...