Conectar Oracle6i y PHP

CarlosLL
25 de Noviembre del 2004
Hola a todos,

Estoy de becario de informática en una empresa donde he acordado hacer mi PFC, pero tengo un problema nada más empezar:

Debo hacer una aplicación web en PHP4 (una intranet) y debo trabajar con la BD que tienen aquí (Oracle6i). Existe algún tipo de incompatibilidad entre versiones? Lo pregunto porque navegando he conseguido varios pedazos de código para conectar la BD mediante PHP, he copiado las librerias php_oracle.dll y php_oci8.dll a los directorios necesarios para que PHP acepte las funciones Oracle, pero no hay modo de que funcione y siempre me devuelve un error "no se ha definido la función LogOn", como si no tragara con las dlls, no se si por culpa de las versiones.

Alguien que domine Oracle ha trabajado alguna vez con PHP? O alguien que domine PHP ha trabajado con Oracle?

Ayuda plis, porque a este paso ni empiezo ni acabo el proyecto!!!!

jc3000
25 de Noviembre del 2004
Lo primero, Oracle 6i no existe
Lo segundo, ni idea de PHP

CarlosLL
25 de Noviembre del 2004
pues como no estoy familiarizado con Oracle y además no lo instalé yo (ya estaba instalado cuando vine) te diré que creo que tengo Oracle8ypico, con los runtimes de Forms y Reports 6i

(así te vale?)

Gustavo
25 de Noviembre del 2004
Hola:
Pienso que deberias utilizar Oracle 8