No me conecta el forms developer

priseo
21 de Enero del 2005
Hola buenas tengo la bd oracle 8i en un PIII k es cliente servidor con win98 y me conecta a la base de datos con los siguientes pogramas golden32 goldview.sql plus, pledit, al conectarme me pone en nombre de la base de datos y el usuario hasta aki bien pero el problema es k con el forms builder me dice k ora-12154: TNS: no se ha podido resolver el servicio y no lo entiendo espero k me puedan ayudar gracias

tu
21 de Enero del 2005
¿ en el golden al hacer un log in pones cadena conexion ( casilla database ) ?
Me figuro que no.
En el developer si que tienes que ponerla. Vete a \ORACLE_HOMEnet80admin y mira en el TNSNAMES.ORA el nombre de tu BBDD, tienes que ver algo así :
ora8.world =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS =
(PROTOCOL = TCP)
(Host = 127.0.0.1)
(Port = 1521)
)
)
(CONNECT_DATA = (SID = ora8)
)
)
EL ora8 es la cadena de conexión

priseo
21 de Enero del 2005
El nombre de mi cadena de conexion es o8start y si k le pongo la cadena de conexion de hecho pone [email protected] vamos como k esta conectado a o8start pero el forms no lo reconoce
Gracias por tu interes

tu
21 de Enero del 2005
Pues entonces copia el TNSNAMES.ORA que tienes en \oracle_homeNET80admin en \oracle_homeNETWORKadmin
Te deberia funcionar. Si no te rula revisa el sqlnet.ora que está en el mismo directorio que el tnsnames.ora y revisa que esté así

AUTOMATIC_IPC = OFF
TRACE_LEVEL_CLIENT = OFF
names.directory_path = (TNSNAMES)
names.default_domain = world
name.default_zone = world