array_walk() y version de PHP

Barbara
20 de Abril del 2006
Buenas tardes, espero que puedan ayudarme con este problema. Al subir la pagina a un servidor que creo que tiene una versión de PHP diferente (más antigua) me sale el siguiente error justo en la linea donde aparece la funcion array_walk

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of array_walk(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/.sites/86/site185/web/Administrador/index2.php on line 406

En la linea 406 pone:
@array_walk($campos_mostrar,\"obtener_campos_select\",&$campos_select);

He intentado kitar & de la tercera variable y no sale el error pero no me muestra los datos en la tabla.

Alguien sabe a que puede deberse o como solucionarlo?? Muchas gracias