Caidas del servidor

ginet11
25 de Mayo del 2006
hola a todos!

Vereís, ultimamente mi server dedicado no hace mas que caerse y caerse y la verdad es que no se por que ocurre. Es un AMD 3500 con 2gb de memoria.

Yo les expliqué a los del host que donde pone "free memory" en el panel de control, esa cifra bajaba al cabo de las horas hasta quedarse sin memoria física y tirar de la virtual, hasta que llega un momento que se petaba todo y me dijeron que era por que alguna aplicación no se cerraba bien o las sesiones, y no se que hacer la verdad.

Estas caidas suceden cada 1-2 dias mas o menos y bueno ahora como solución un poco chapuza he puesto un reinicio automático de la máquita durante la madrugada, ya que así la memoria sigue bajando pero desde mas arriba digamos XD.

Lo único raro que he visto en los logs es en el de errores que me muestra varias veces por segundo estas lineas:
[Wed May 24 12:40:39 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:39 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:42 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:44 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:44 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:44 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:45 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
[Wed May 24 12:40:45 2006] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!

Pero la verdad es que no creo que eso afecte al tema de las caidas o si??

Bueno me quedo a la espera de vuestros sabios consejos!

Gracias y un saludo!

jamiroquai
25 de Mayo del 2006
En mi hogar puse hace un tiempo un server, claro que este server era un athlon xp de 1.7 solamente y tenia 1 gb de ram.

La cosa es que tambien tuve problemas con el tema de la memoria y por lo menos a mi, me funciono creando un script .bat en windows o .c en linux, que liberara el cache de la memoria y los temporales.

Eso lo hice pues la cache de la memoria en mi equipo, luego de utilizarla por mucho tiempo, comenzaba a utilizar los recursos del equipo (memoria virtual), y asi entonces programe una tarea en win y lo corria una vez en la madrugada y una a medio dia.

Con respecto a los errores que pones aca, esas son solo noticias (fijate que dice [notice] y al final dice ¡ignoring!) y podrian ser producto de alguna configuracion mal hecha en el servidor ya que el error indica que al enviar la pagina de error 401 no puede utilizar la URL completa.

Bueno... espero que te sirva de algo.