error con mysql_connect

ares_pre
03 de Julio del 2005
Mi problema es el siguiente. Al ejecutar:
<HTML>
<HEAD>
<TITLE> Conectar MySQL desde PHP </TITLE>
</HEAD>
<BODY>
<?PHP
$link = mysql_connect("localhost", "root", "root");
mysql_select_db("mysql", $link);

?>
</BODY>
</HTML>

Me da el siguiente mensaje de error:
Fatal error: Call to undefined function mysql_connect() in C:InetpubwwwrootPHPConectar.php on line 7

Tengo instalado un PHP 5.0.3 con un MySQL 4.1.9 (pero ya lo probe tambien con la version 4.0.23 y 5.0.2) corriendo sobre un IIS.
He verificado que todo funciona correctamente por separado, la BBD de My SQL funciona y varias paginas que me echo en PHP tambien. He recorrido el foro buncando soluciones y no encuentro nada.
ALGUIEN ME PUEDE AYUDAR. Muchas gracias.

jose
03 de Julio del 2005
yo tengo php 5.0.4 y mysql 4.1.12a
pues yo lo que hice fue lo siguiente:
Añadí la ruta de las extensines de php en php.ini
extension_dir = "E:/php5/ext"
Añadí una línea en la parte de las extensiones de ese archivo
;extension=php_msql.dll
;extension=php_mysql.dll
;ESTA LINEA FUE LA Q AÑADÍ
extension=php_mysqli.dll
;extension=php_oci8.dll
;extension=php_openssl.dll
;extension=php_oracle.dll
;extension=php_pdf.dll

espero le sirva. chao

forgin
03 de Julio del 2005
hola, sintacticamente creo que esta bien escrito, comprueba que el usuario y contraseña (.... "root", "root"); esten bien escritos y si sigue sin funcionarte, si lo que kieres es crear una conexion con la base de datos, puedes usar esta que uso yo, solo tienes que ponerla en cada pagina que tengas que conectarte con la base de datos, yo lo hago mediante incluedes o requires.



<?php

function conectarse(){
$host = 'localhost';
$username = 'nombre_usuario';
$pw = 'contraseña';
$db = 'base_de_datos';
mysql_connect($host, $username, $pw);
mysql_select_db($db);
};
?>

ares_pre
03 de Julio del 2005
No te creas,tambien lo intente como me propones y seguimos en las mismas. ¿Tu que versiones de PHP y MySQL usas para que te funcione?
Muchas gracias.

forgin
03 de Julio del 2005
php 4.3.9.9 y mySQL 4.0.23

ares_pre
03 de Julio del 2005
Muchas gracias socio, esto y esta funcionando perfectamente.
salu2.

Alex
03 de Julio del 2005
Hola, deberías leer el mensaje de error que te manda, en PHP 5 ya no viene incluido la extensión php_mysql como en versiones anteriores, tienes 2 opciones: utilizar la versión mejorada php_mysqli.dll o la antigua php_mysql.dll, puedes habilitarlas desde el php.ini, en la parte de extensiones.

Saludos
www.buayacorp.com

ares_pre
03 de Julio del 2005
Pienso como tu, que tiene que ver bastante con las versiones de PHP o MySQL que utilizo. Tambien me di una vuelta por el PHP.ini para desdocumentar ciertas lineas y/o debo haberlas pasado por alto o no figura nada que haga referencia a esas funciones o extensiones. Muchas gracias por la pista.