problemas con el japones en php

David Carrero Fdez-Baillo
17 de Marzo del 2005
Te paso el problema de japones por si sabes o conoces a alguien a ver si no puedes echar un cable ...

Hola a [email protected],

Tengo montado un buscador multi-idioma que funciona perfectamente en español e inglés pero, en japonés no va.

El caso es que, para realizar las búsquedas tengo que convetir algo del tipo: ー・デ a ー・デ porque es en este formato en el que se guardan los datos.

Si introduzco la cadena ー・デ el buscador funciona sin ningún cambio, pero si la introduzco como lo haría un "japonés autóctono" ー・デ no lo localiza.

Según la documentación de que dispongo bastaría con pasar la cadena por htmlspecialchars(), pués bien, lo he probado en una máquina local con PHP5 y me lo convierte sin problemas, pero en mi servidor no lo convierte.

Sabéis porqué puede suceder esto ?? que parámetros o variables hay que tocas en el php.ini ??
He consultado información sobre "Multibyte String Functions" (http://php.planetmirror.com/manual/es/ref.mbstring.php), he hecho algunos cambios en el php.ini pero no consigo que realizar la conversión.
Se agradece cualquier información al respecto.


--
Saludos
David Carrero Fernández-Baillo
Director General y Comercial
Atención Comercial : 902 333 932
Fax : 91 141 21 38
Ferca Network
www.ferca.com
www.recursosgratis.com



Micha-kun
17 de Marzo del 2005
pero escribirlo asi es demasiado matada :S ademas, si lo que tienes es la informacion en MYSQL, para que funcione tienes que acceder a ella tambien en Unicode para que tire bien.