tengo un error con php y apache

Jorge B.
13 de Agosto del 2003
He instalado PHP-4.0.6 y APACHE 1.3.28 en Linux 7.3 todo instala perfectamente, modifico el httpd.conf, arranco el servidor apache y verifico la que el servidor funcione (http://127.0.0.1) y dice que esta instalado correctamente, busco a pagina que me da esa informacion (index.html), la rempazo por una html y funciona, pero cuando coloco un el ejemplo sencillo de .php me pregunta que si quiero abrir ese archivo, guandarlo o cancelar. Si le digo que lo abra me pregunta que con que editor. No me muestra la pagina php

si alguien sabe le agradeceria la ayuda. supongo que es una bobada, pero no se que es.

muchas gracias a quien me pueda ayudar

JORGE B.

fLIPIS
13 de Agosto del 2003
Has de decirle a Apache que las páginas php son para interpretar. Añade estas líneas en tu httpd.conf

AddType application/x-httpd-php .php .php3 .phtml .php4

En principio con eso debería bastar. Reinicia el servidor y prueba a ver si funciona.

Un saludo