isapi_redirect

pez
26 de Febrero del 2003
Estoy intentando instalar el filtro isapi_redirect.dll en IIS5.0 y creo que lo intente casi todo. Creé el directorio virtual

jakarta en mi Sitio Web predeterminado que apunta al lugar donde tengo el archivo isapi_redirect.dll, dentro de la

instalación de Tomcat: D:jakarta-tomcatbinnative, le concedo todos los permisos (tb ejecución).

Probé a añadir el filtro en propiedades de mi sitio web predeterminado y en propiedades de mi ordenador (en propiedades

principales de www, donde hay otros cargados).

Tb probé a instalar el filtro en el directorio de donde coge otros que si carga : D:WINNTSystem32inetsrv pero nada. No

paso de la flecha roja, o sea que no me lo carga.

Cuando añado un directorio virtual a mi Sitio predeterminado me lo crea con un simbolo de error al lado del nombre. Al igual

que el resto de los que hay por defecto: Script,IISAdmin, IISSamples,... (me parece raro). A pesar de todo IIS si que me

funciona normalmente con mis paginas html y asp.

El archivo genarado con jkconf está bien, es como sigue:

REGEDIT4

[HKEY_LOCAL_MACHINESOFTWAREApache Software FoundationJakarta Isapi Redirector1.0]
"extension_uri"="/jakarta/isapi_redirect.dll"
"log_file"="D:\jakarta-tomcat\logs\iis_redirect.log"
"log_level"="emerg"
"worker_file"="D:\jakarta-tomcat\conf\jk\workers.properties"
"worker_mount_file"="D:\jakarta-tomcat\conf\auto\uriworkermap.properties"
"uri_select"="parsed"

El Tomcat tb me sirve paginas jsp. Me parece error de IIS, pero no se cual. Alguien puede ayudarme, auxiliooo !!

jesus
26 de Febrero del 2003
Estoy buscando respuesta a tu mismo problema: Cuando creo un directorio virtual en el IIS, me pone el símbolo de error al lado del nombre y no funciona. Lo curioso es que ese mismo directorio virtual (que se encuentra en otro servidor) lo mapeo sin ningún problema. ¿Como arreglaste el problema?