jdeveloper, adfs y jdk1.3.1_01

yop
15 de Julio del 2005
sabéis si es posible usar el framework de oracle ADF con el jdk1.3.1_01? es que me da el siguiente error de ejecución en jdeveloper:
"java.lang.NoSuchMethodError
at oracle.jbo.http.HttpSessionCookieHelperImpl.readCookieValue(HttpSessionCookieHelperImpl.java:44)
at oracle.jbo.http.HttpSessionCookieImpl.readValue(HttpSessionCookieImpl.java:189)
at oracle.jbo.http.HttpSessionCookieImpl.<init>(HttpSessionCookieImpl.java:101)
at oracle.jbo.http.HttpSessionCookieFactory.createSessionCookie(HttpSessionCookieFactory.java:103)
at oracle.jbo.common.ampool.ApplicationPoolImpl.createSessionCookie(ApplicationPoolImpl.java:418)
at oracle.adf.model.bc4j.DataControlFactoryImpl.findOrCreateSessionCookie(DataControlFactoryImpl.java:154)
at oracle.adf.model.bc4j.DataControlFactoryImpl.createSession(DataControlFactoryImpl.java:220)
at oracle.adf.model.bc4j.DataControlFactoryImpl.createSession(DataControlFactoryImpl.java:97)
at oracle.jbo.uicli.mom.JUMetaObjectManager.loadCpx(JUMetaObjectManager.java:612)
at oracle.adf.model.servlet.ADFBindingFilter.initializeBindingContext(ADFBindingFilter.java:328)
at oracle.adf.model.servlet.ADFBindingFilter.doFilter(ADFBindingFilter.java:173)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:600)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:270)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:112)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186)
at java.lang.Thread.run(Thread.java:484)
"

y en cambio con el jdk1.4.2_08 o el jdk1.4.2_03 funciona perfectamente. Es por incompatibilidad con el 1.3? o puede ser cualquier otro tipo de fallo (mal configurado el classpath, no instalación de las librerías...).
Estoy mirando como loco por todas partes pero no encuentro nada sobre el tema.

gracias, un saludo.