Nesesito Api??

Carlos
18 de Febrero del 2003
Hola en estos dias estuve viendo un manual en cual decia que tenia que estar instalado el api para servlet, pero fui a buscarlos a la pag de sun y no encontre nada, cada vez me perdia mas y no llegaba a ningun lado fue Desastrosos!!.
Y la verdad no se si me bastara con el jdk1.3
no estoy seguro si este tiene el api en el manual que estaba leyendo decia que para ejecutar los servlets estaba una aplicaccion similar al appletviewer. No se si sea cierto.
Agradesco a a quellos que se interecen en mi duad y me ayuden a resolverla. Gracias de antemano

OjoNegro
18 de Febrero del 2003
Menuda mezcla de cosas. Yo no soy un experto pero siegún entiendo necesitas del paquete para compilar y correr Servlets ¿es asi? De sere asi, estas clases se encuentran en el J2EE (la ulltma version es la 1.4) y creo que NO estan en el J2SE que debe ser el que tu tienes (aclaro que "creo" que es asi). Por lo que tendrías que bajarte el Java 2 Enterprise Edition 1.4 y allí se encuentra el paquete "javax.servlet.http" que es el que tu necesitas.
Ahora bien, para correr los servlets necesitas de un contenedor web, y como alternativa más sencilla a la que te han dado, sugiero el Apache Tomcat 4.01 que es uno de los más usados y puedes descargarlo de jakarta.apache.org. Vale acalrar que en el directorio "lib" del Tomcat también se encuentra el paquete "javax.servlet.http" con lo que matas 2 pájaros d un tiro.
Eso es todo, cualquier duda puedes escribir. Hasta luego

Ivan
18 de Febrero del 2003
Si aun no haz resuelto tu duda a qui te va, es cierto existe un comando parecido al apletviewer, pero si estas interesado en servlet, primero debes tener un servidor web te recomiendo apache, y en el debes configurar los archivos http.conf, jserv.con y jserv.properties alli deberas darle la direccion donde se van encontruar los jar de tus servlets que tambien deberas obtener y tambien deberas darle esta direccion al classpath, espero te haya servido solo para empesar en los servlet