Pagina en blanco en struts (aprendiendo)

Sergio
11 de Julio del 2005
Estoy intentando hacer funcionar una aplicación básica y obtengo como resultado una página en blanco. Estoy con eclipse 3.0.2 tomcat 5.0 y struts 1.2.7

Os situo el código:

struts-config.xml

<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD Struts Configuration 1.1//EN" "http://jakarta.apache.org/struts/dtds/struts-config_1_1.dtd">
<struts-config>
<action-mappings>
<action path="/usuarioListarAction" type="UsuarioListarAction">
<forward name="success" path="/index.jsp"/>
</action>
</action-mappings>
</struts-config>

Action:
public final class UsuarioListarAction extends Action{


public ActionForward execute(ActionMapping mapping,
ActionForm form,
HttpServletRequest req,
HttpServletResponse res)
throws Exception {

return mapping.findForward("success");
}
}

Bueno pues en lugar de sacarme un hola mundo me saca una página en blanco¡¡
index.jsp se encuentra en el raiz, vamos q la localización está bien.

Alguna idea?

Muchas gracias¡¡

Rascayu
11 de Julio del 2005
Por decirte algo, prueba a quitar "final" de la clase Action y supongo que tendrás declarado en web.xml lo siguiente:

<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>

¿no? Suerte.

Sergio
11 de Julio del 2005
El problema estaba en que eclipse no me estaba avisando de que el código no estaba siendo actualizado en tomcat.

Quiero decir:
El codigo puesto está bien, pero el código q tenía tomcat usaba el método "perfom" en lugar de execute. Esta mañana cuando he arrancado el ordendor, me ha avisado de un fallo, lo he solucionado y la aplicación ha podido instalarse de nuevo en tomcat y esta vez funcionando¡¡

Muchas gracias¡¡