Problemas con el archivo web.xml

gmocontreras
26 de Octubre del 2007
Hola amigos,
Mi problema es el siguiente, resulta que tengo instalado tomcat 5 en mi windows, el jsp me funciona bien el problema se da con los SERVLET he creado un servlet Hola mundo.
pero al momento de agregarlo al archivo web.xml me manda el siguiente error.

Este es mi servlet
=========================================

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>

<display-name>Aplicacion para Ingenieria de Software</display-name>
<description>Esta aplicacion administra los recursos informaticos.</description>
<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>
<servlet>
<servlet-name>ing_sw</servlet-name>
<servlet-class>HolaMundo</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>prueba</servlet-name>
<url-pattern>hola</url-pattern>
</servlet-mapping>
</web-app>

este es el ERROR
=====================
FALLO - No se pudo arrancar la aplicación en trayectoria de contexto /ing_sw, este error sale cuando entro al "Gestor de Aplicaciones Web de Tomcat" y le doy Arrancar a la aplicacion /ing_sw(es una aplicación simple).

Esto no me pasa cuando dejo el archivo web.xml de esta manera.
==========================================
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>

<display-name>Aplicacion para Ingenieria de Software</display-name>
<description>Esta aplicacion administra los recursos informaticos.</description>
<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>
</web-app>

de la segunda forma me funciona bien, quizas me falta darle bien la ruta del servlet:
Esta es mi estructura
->/ing_sw
|___WEB-INF
|___classes
|___HolaMundo.class
|___web.xml
|___index.jsp

Si me pudieran ayudar se los agradeceria mucho.


ecdl
26 de Octubre del 2007
las clases tienen que estar dentro del directorio classes.

también deberías hacer un package...

Juan
26 de Octubre del 2007
Tengo el mismo problema. el mensaje de error es falta el archivo web.xml de la aplicacion utilizando los parametros por defecto
StandardEngine[Catalina].StandardHost[LocalHost]

Jorge
26 de Octubre del 2007
Di muchas vueltas por este problema pero todo esta en que si esta mal hecho el WEB.xml o si lo que indica no tiene la respectiva estructura de directorios / archivos, tampoco arrancara.