AYUDA CON ESTE CODIGO

dradana2003
17 de Agosto del 2005
estoy realizando una aplicacion con una conexion a sql con el dataenviromen y me da error
el codigo es este

If DataEnvironment1.Connection1.State = 1 Then DataEnvironment1.Connection1.Close


With DataEnvironment1.rsAlumnos
.Fields("Nombre") = Text1.Text
.Fields("Apellido") = Text2.Text
.Update
End With


DataEnvironment1.Connection1.Close

MsgBox ("LOS DATOS HAN SIDO SALVADOS")

me dice que no encuentra el termino soliitado. se supone que esto trabaje como un ado y que para actualizar el este en el registro y con solo el udate al final se actualize el registro

pero me da ese error

Saludos

dradana2003
17 de Agosto del 2005
ayuden con esto por favor

dradana2003
17 de Agosto del 2005
EL PROBLEMA SOLO LO TENGO EL METODO UDDATE, EL RESTO TRABAJA BIEN, EL ERROR QUE ME DA AHORA ES QUE HAY MULTIPLES ERRORES EN LOS PASOS DATOS.
INCLUSO LO PUSE EN UN DATAGRI Y ME SIGUE DANDO EL MISMO PRONBLEMA

migumu
17 de Agosto del 2005
¿Es posible que tengas un BOF o EOF?
Lo digo porque si no encuentra el metodo en la colección puede ser que no tengas datos para acualizar.
Prueba a hacer un find del registro que estas intentado modificar.

¿Puedes usar ADO?

Roberto Larios
17 de Agosto del 2005
Solo agrega la palabra ".addnew"
*--*-------------------------------------------

If DataEnvironment1.Connection1.State = 0 Then DataEnvironment1.Connection1.open


With DataEnvironment1.rsAlumnos
.addnew
.Fields("Nombre") = Text1.Text
.Fields("Apellido") = Text2.Text
.Update
.close
End With

MsgBox ("LOS DATOS HAN SIDO SALVADOS")