Ayuda en validacion

Gandalf
28 de Mayo del 2004
que tal amigos tengo una pregunta para ver si me pueden ayudar con un codigo.
Resulta que tengo un informe en excell con formulas donde trabajo con varias cantidades. bueno el pequeño modulo consiste en tomar el textbox1 y el textbox2 y sumarlos en el textbox3 y al darle clip para validacion a las celdas seleccionadas la misma se copia pero el problema está que en la parte superior tengo una formula que sumas esas celdas, pero al validar el total que está en los textbox no lo suma. les copio el codigo para k lo observen.
Private Sub CommandButton1_Click()
ValidarCampos
End Sub

Private Sub CommandButton2_Click()
Unload Sumar
End Sub

Private Sub TextBox3_enter()

TextBox3.Value = (-TextBox2.Value - TextBox1.Value)


End Sub




Private Sub ValidarCampos()

Dim Error As String
Dim ValorMensaje As Integer

Error = "Error en los datos del formulario"

If Len(TextBox1.Text) = 0 Then

ValorMensaje = MsgBox("El campo Numero 1 está vacio", _
vbOKOnly, Error)

TextBox1.SetFocus
Else

If Len(TextBox2.Text) = 0 Then

ValorMensaje = MsgBox _
("El campo numero 2 está vacio", vbOKOnly, Error)

Textsbox2.SetFocus
Else

With ActiveCell
.Value = TextBox3


End With

ActiveCell.Offset(1, 0).Activate

BorrarFormulario
End If
End If
End Sub
Private Sub BorrarFormulario()
TextBox1.Value = ""
TextBox2.Value = ""
TextBox3.Value = ""
End Sub


bueno trataré de ser mas especifico pork pienso k no fui muy claro.
Tengo text1 y text2 que el total queda en el text3 al darle validar los campos los copia en las celdas pero no afecta en el total de la formula que es =SUMA(H5:H6)
pero si lo hago manual si.
Espero que sean tan amables or favor y me ayuden en esto.
Ah cabe señalar que soy principiante en esto.

Gracias

Cristian
28 de Mayo del 2004
Hola

Al mirar el codigo que colocaste me fije en una cosa si este es el mismo que estas utlilizando te ace falta algo.

Se supone que al darle Click al boton CommandButton1 te lleva al metodo ValidarCampos
pero en este metodo por ningun lado esta la operacion que suma los dos Text Text3.Value=(Text1.Value+Text2.Value).

Aunque mas arriba tienes esto:
Private Sub TextBox3_enter()
TextBox3.Value = (-TextBox2.Value - TextBox1.Value)
End Sub
Al parecer esto es el evento Enter del Text3, pero este evento no existe y aqui es donde aparentemente esta la opercacion

Para resumir coloca en el Metodo ValidarCampos():
TextBox3_enter
para que llame el metodo de la operacion
Chao

Juez
28 de Mayo del 2004
Que tal cristian gracias por responder, según entiendo de tu respuesta es que el metodo no está validando el tex3, pero si lo está validando el problema que tengo es que después que valida las cantidades en la celda esa cantidad la formula que está arriba donde debe sumar no reconoce la cantidad como si no existiera, pensé que era la formula pero si lo hago manual si funciona.
ah de acuerdo al evento se cambio a :
TextBox3.Value = (Val(-TextBox2.Value) - Val(TextBox1.Value))