Ayuda con informes

Sam
07 de Septiembre del 2003
Hola a todos...
Estoy haciendo un informe para visualizar una imagen y unos campos con informacion de la misma. La imagen se muestra correctamente pero con los campos tengo un problemon y es que se visualizan en el informe tantas veces como numeros de registros tengo en la tabla...!, se tendrian q ver en una sola linea ya que tienen la informacion de una consulta con un resultado unico.
Me explico:
Creo una consulta por codigo dentro de un boton y la almaceno en un cursor: "Select nomfoto, numfoto from fotos where nufoto=5 into cursor cfoto"
En el informe tengo los campos vinculados a este cursor (cfoto.nomfoto....etc)
El informe me tendria q mostrar el resultado una sola vez junto con la foto, pero en vez de eso, me muestra el mismo resultado unico tantas veces como numero de registros tengo en la tabla

FOTO
=================================
numfoto: 5 nomfoto: logo

numfoto: 5 nomfoto: logo

numfoto: 5 nomfoto: logo

Etc...
Porque me repite el resultado tantas veces como registros tengo ...??????????
Llevo poco tiempo en foxpro, espero me puedas echar una mano, me estoy volviendo loco y seguro q es una tonteria, no se q es lo q se me escapa.....

Gracias y un saludo fieras.....


osvaldo
07 de Septiembre del 2003
me parece que la instruccion , select esta bien:
puedes revisar para ver si en el Where los campos que utilizas en la condicon son iguales, por ejemplo:
si tienes el campo, nufoto = "5 " y lo compara con "5", no son iguales porque nufoto tiene un espacio, entonces tendrias que: alltrim(nufoto) = "5" , ahora si son iguales.
tambien puedes revizar luego que heces la consulta y llamas el informe, que el cursor con los datos este activo ejemplo:
SELECT cfoto
GO TOP
entonces llamas el formulario.
espero te ayude de algo, me escribes para ver como te fue..

Sam
07 de Septiembre del 2003
Gracias Osvaldo por tu colaboracion:
He hecho las comprobaciones que me dijiste, pero el problema creo que no esta ahi puesto que me sigue dando el mismo problema con el informe.
Aqui te pongo el codigo del boton "preview" que tengo, estan sencillo que no se donde puede estar el fallo:
&&=================
Select itplan
go top
Select nuplan, noplan, catpla, scatpl from itplan ;
where nuplan=5 into cursor cplano
&&where alltrim(str(nuplan))="5" into cursor cplano

Select cplano
go top
REPORT FORM C:foxproinform1 preview
&&===============================

Puede que el fallo este en el informe...??
Si puedes echarme un cable... es lo unico que me queda para terminar la aplicacion, llevo una par de dias liado con esto y el jefe de la empresa quiere ver ya resultados............
Gracias de nuevo