Nuevo Tomcat 5.5 (y 5.5.1)

A partir de ahora no será obligatorio tener instalado la JDK para poder compilar JSPs, ya que utiliza el compilador de Eclipse JDT. Por tanto solo será necesario instalar la JRE. Además, está totalmente orientado a ejecutarse en la nueva versión de java, la 5.0, aunque es capaz de funcionar con la 1.4.

Otros cambios son:

  • Uso extensivo de los commons-logging, eliminandose el org.apache.catalina.Logger
  • El classloader se ha refactorizado, para un mejor manejo del los JARs y el bloqueo de recursos.
  • Aprovechando las nuevas funcionalidades en JMX de J2SE 5.0, se ha incorporado código relacionado con JMX.
  • Se ha mejorado el tiempo de arranque, a la vez que se ha optimizado el mapeo de peticiones.

Fuente: javaHispano.

COMPARTE ESTA NOTICIA

ENVIAR A UN AMIGO
COMPARTIR EN FACEBOOK
COMPARTIR EN TWITTER
COMPARTIR EN GOOGLE +